import re
regex = re.compile(r"([^\n,]++)(?=.*,([^\n,@]+$)),(?:(?1)(?:\n|$))?", flags=re.MULTILINE)
test_str = ("johnsmith1@gmail.com,johnsmith2@gmail.com,johnsmith3@gmail.com,John Smith\n"
"taylorsmith@gmail.com,Taylor Smith\n"
"jacksmith1@gmail.com,jacksmith@gmail.com,Jack Smith\n")
subst = "$2,$1\\n"
result = regex.sub(subst, test_str)
if result:
print(result)