package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?U)public(.|\n)+{`)
var str = ` public ActionResult AddCompatibleWith(AttributeValue printer, string sku)
{
var isAuthenticated = _customerContext.LoggedInCustomer != null;
var model = new CompatibleWithModel();
if (isAuthenticated && _customerContext.LoggedInCustomer.SavedPrinters.Select(x => x.AttributeValue.Key).Contains(printer.Key))
{
model.Url = Url.Action(
"MyPrinters",
"Manage",
new
{
area = "my_account"
});
model.Text = SiteResources.View;
model.CssClass = "btn";
}
else`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}