#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:<AdrLine>.+?</AdrLine>\s*)+"
Local $sString = "<Head>" & @CRLF & _
" <Post>value</Post>" & @CRLF & _
" <PstlAdr>" & @CRLF & _
" <Ctry>…</Ctry>" & @CRLF & _
" <AdrLine>line1</AdrLine>" & @CRLF & _
" <AdrLine>line2</AdrLine>" & @CRLF & _
" <AdrLine>line3</AdrLine>" & @CRLF & _
" <AdrLine>line4</AdrLine>" & @CRLF & _
" </PstlAdr>" & @CRLF & _
" <PstlAdr>" & @CRLF & _
" <Ctry>…</Ctry>" & @CRLF & _
" <AdrLine>line1</AdrLine>" & @CRLF & _
" <AdrLine>line2</AdrLine>" & @CRLF & _
" <AdrLine>line3</AdrLine>" & @CRLF & _
" <AdrLine>line4</AdrLine>" & @CRLF & _
" </PstlAdr>" & @CRLF & _
"" & @CRLF & _
"</Head>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")