import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:<AdrLine>.+?</AdrLine>\\s*)+";
final String string = "<Head>\n"
+ " <Post>value</Post>\n"
+ " <PstlAdr>\n"
+ " <Ctry>…</Ctry>\n"
+ " <AdrLine>line1</AdrLine>\n"
+ " <AdrLine>line2</AdrLine>\n"
+ " <AdrLine>line3</AdrLine>\n"
+ " <AdrLine>line4</AdrLine>\n"
+ " </PstlAdr>\n"
+ " <PstlAdr>\n"
+ " <Ctry>…</Ctry>\n"
+ " <AdrLine>line1</AdrLine>\n"
+ " <AdrLine>line2</AdrLine>\n"
+ " <AdrLine>line3</AdrLine>\n"
+ " <AdrLine>line4</AdrLine>\n"
+ " </PstlAdr>\n\n"
+ "</Head>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}