use strict;
my $str = '<Head>
<Post>value</Post>
<PstlAdr>
<Ctry>…</Ctry>
<AdrLine>line1</AdrLine>
<AdrLine>line2</AdrLine>
<AdrLine>line3</AdrLine>
<AdrLine>line4</AdrLine>
</PstlAdr>
<PstlAdr>
<Ctry>…</Ctry>
<AdrLine>line1</AdrLine>
<AdrLine>line2</AdrLine>
<AdrLine>line3</AdrLine>
<AdrLine>line4</AdrLine>
</PstlAdr>
</Head>';
my $regex = qr@(?:<AdrLine>.+?</AdrLine>\s*)+@p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}