$re = '@(?:<AdrLine>.+?</AdrLine>\s*)+@';
$str = '<Head>
<Post>value</Post>
<PstlAdr>
<Ctry>…</Ctry>
<AdrLine>line1</AdrLine>
<AdrLine>line2</AdrLine>
<AdrLine>line3</AdrLine>
<AdrLine>line4</AdrLine>
</PstlAdr>
<PstlAdr>
<Ctry>…</Ctry>
<AdrLine>line1</AdrLine>
<AdrLine>line2</AdrLine>
<AdrLine>line3</AdrLine>
<AdrLine>line4</AdrLine>
</PstlAdr>
</Head>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);