package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:<AdrLine>.+?</AdrLine>\s*)+`)
var str = `<Head>
<Post>value</Post>
<PstlAdr>
<Ctry>…</Ctry>
<AdrLine>line1</AdrLine>
<AdrLine>line2</AdrLine>
<AdrLine>line3</AdrLine>
<AdrLine>line4</AdrLine>
</PstlAdr>
<PstlAdr>
<Ctry>…</Ctry>
<AdrLine>line1</AdrLine>
<AdrLine>line2</AdrLine>
<AdrLine>line3</AdrLine>
<AdrLine>line4</AdrLine>
</PstlAdr>
</Head>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}