#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?![Nn][Aa][Mm][Ee]$)[A-Za-z][A-Za-z0-9 ]*$"
Local $sString = "Name" & @CRLF & _
"NAME" & @CRLF & _
"NaMe" & @CRLF & _
"Some text here" & @CRLF & _
"naME" & @CRLF & _
"nam" & @CRLF & _
"nam1" & @CRLF & _
"name1" & @CRLF & _
"1name" & @CRLF & _
"theName" & @CRLF & _
"N1ame" & @CRLF & _
"helloname" & @CRLF & _
"whatisyourname"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")