re = /^(?![Nn][Aa][Mm][Ee]$)[A-Za-z][A-Za-z0-9 ]*$/m
str = 'Name
NAME
NaMe
Some text here
naME
nam
nam1
name1
1name
theName
N1ame
helloname
whatisyourname'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end