use strict;
my $str = 'Name
NAME
NaMe
Some text here
naME
nam
nam1
name1
1name
theName
N1ame
helloname
whatisyourname';
my $regex = qr/^(?![Nn][Aa][Mm][Ee]$)[A-Za-z][A-Za-z0-9 ]*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}