$re = '/^(?![Nn][Aa][Mm][Ee]$)[A-Za-z][A-Za-z0-9 ]*$/m';
$str = 'Name
NAME
NaMe
Some text here
naME
nam
nam1
name1
1name
theName
N1ame
helloname
whatisyourname';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);