const regex = /^(?![Nn][Aa][Mm][Ee]$)[A-Za-z][A-Za-z0-9 ]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?![Nn][Aa][Mm][Ee]$)[A-Za-z][A-Za-z0-9 ]*$', 'gm')
const str = `Name
NAME
NaMe
Some text here
naME
nam
nam1
name1
1name
theName
N1ame
helloname
whatisyourname`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}