# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\d\d)([.:])(?!\d+)/ \1 /gm;t' <<< "1992.01.04 is my birthday.
The time is 11:48, reported by: Tom."