#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<!\d\d)([.:])(?!\d+)"
Local $sString = "1992.01.04 is my birthday." & @CRLF & _
"The time is 11:48, reported by: Tom."
Local $sSubst = " \1 "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)