$re = '/(?<!\d\d)([.:])(?!\d+)/m';
$str = '1992.01.04 is my birthday.
The time is 11:48, reported by: Tom.';
$subst = " \1 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;