using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\d\d)([.:])(?!\d+)";
string substitution = @" \1 ";
string input = @"1992.01.04 is my birthday.
The time is 11:48, reported by: Tom.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}