import Foundation
let pattern = #"(?<!\d\d)([.:])(?!\d+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1992.01.04 is my birthday.
The time is 11:48, reported by: Tom.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" \1 "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)