#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!$)(?:\d+\s+years?)?(?:(?:\h+|^)\d+\s+months?)?(?:(?:\h+|^)\d+\s+weeks?)?(?:(?:\h+|^)\d+\s+days?)?(?:(?:\h+|^)\d+\s+hours?)?(?:(?:\h+|^)\d+\s+minutes?)?(?:\h+\d+\s+seconds?)?$"
Local $sString = "2 days" & @CRLF & _
"3 years" & @CRLF & _
"12 hours" & @CRLF & _
"2 days 6 hours 30 minutes" & @CRLF & _
"" & @CRLF & _
"4352 YEARS 2 weeks 4 days 5 days 2 minutes 30 second"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")