import Foundation
let pattern = #"^(?!$)(?:\d+\s+years?)?(?:(?:\h+|^)\d+\s+months?)?(?:(?:\h+|^)\d+\s+weeks?)?(?:(?:\h+|^)\d+\s+days?)?(?:(?:\h+|^)\d+\s+hours?)?(?:(?:\h+|^)\d+\s+minutes?)?(?:\h+\d+\s+seconds?)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
2 days
3 years
12 hours
2 days 6 hours 30 minutes
4352 YEARS 2 weeks 4 days 5 days 2 minutes 30 second
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)