using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!$)(?:\d+\s+years?)?(?:(?:\h+|^)\d+\s+months?)?(?:(?:\h+|^)\d+\s+weeks?)?(?:(?:\h+|^)\d+\s+days?)?(?:(?:\h+|^)\d+\s+hours?)?(?:(?:\h+|^)\d+\s+minutes?)?(?:\h+\d+\s+seconds?)?$";
string input = @"2 days
3 years
12 hours
2 days 6 hours 30 minutes
4352 YEARS 2 weeks 4 days 5 days 2 minutes 30 second";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}