re = /^(?!$)(?:\d+\s+years?)?(?:(?:\h+|^)\d+\s+months?)?(?:(?:\h+|^)\d+\s+weeks?)?(?:(?:\h+|^)\d+\s+days?)?(?:(?:\h+|^)\d+\s+hours?)?(?:(?:\h+|^)\d+\s+minutes?)?(?:\h+\d+\s+seconds?)?$/m
str = '2 days
3 years
12 hours
2 days 6 hours 30 minutes
4352 YEARS 2 weeks 4 days 5 days 2 minutes 30 second'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end