use strict;
my $str = '2 days
3 years
12 hours
2 days 6 hours 30 minutes
4352 YEARS 2 weeks 4 days 5 days 2 minutes 30 second';
my $regex = qr/^(?!$)(?:\d+\s+years?)?(?:(?:\h+|^)\d+\s+months?)?(?:(?:\h+|^)\d+\s+weeks?)?(?:(?:\h+|^)\d+\s+days?)?(?:(?:\h+|^)\d+\s+hours?)?(?:(?:\h+|^)\d+\s+minutes?)?(?:\h+\d+\s+seconds?)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}