import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(screen_name:\\s+\\S)(\\S*)(\\S)";
final String string = "February 3, 2018 screen_name: FR33Q location: Europe verified: false lang: en";
final String subst = "\\1****\\3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}