// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(screen_name:\s+\S)(\S*)(\S)").unwrap();
let string = "February 3, 2018 screen_name: FR33Q location: Europe verified: false lang: en";
let substitution = "\\1****\\3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}