const regex = /(screen_name:\s+\S)(\S*)(\S)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(screen_name:\\s+\\S)(\\S*)(\\S)', 'g')
const str = `February 3, 2018 screen_name: FR33Q location: Europe verified: false lang: en`;
const subst = `\1****\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);