import re
regex = re.compile(r"(screen_name:\s+\S)(\S*)(\S)")
test_str = "February 3, 2018 screen_name: FR33Q location: Europe verified: false lang: en"
subst = "\\1****\\3"
result = regex.sub(subst, test_str)
if result:
print(result)