$re = '/(screen_name:\s+\S)(\S*)(\S)/';
$str = 'February 3, 2018 screen_name: FR33Q location: Europe verified: false lang: en';
$subst = "\1****\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;