#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=[0-9]*[1-9])[0-9]{1,7}$"
Local $sString = "1" & @CRLF & _
"12" & @CRLF & _
"432" & @CRLF & _
"12414" & @CRLF & _
"1234567" & @CRLF & _
"01" & @CRLF & _
"0121" & @CRLF & _
"0000001" & @CRLF & _
"" & @CRLF & _
"0000000" & @CRLF & _
"0" & @CRLF & _
"12345678"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")