const regex = /^(?=[0-9]*[1-9])[0-9]{1,7}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=[0-9]*[1-9])[0-9]{1,7}$', 'gm')
const str = `1
12
432
12414
1234567
01
0121
0000001
0000000
0
12345678`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}