import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=[0-9]*[1-9])[0-9]{1,7}$";
final String string = "1\n"
+ "12\n"
+ "432\n"
+ "12414\n"
+ "1234567\n"
+ "01\n"
+ "0121\n"
+ "0000001\n\n"
+ "0000000\n"
+ "0\n"
+ "12345678";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}