$re = '/^(?=[0-9]*[1-9])[0-9]{1,7}$/m';
$str = '1
12
432
12414
1234567
01
0121
0000001
0000000
0
12345678';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);