import re
regex = re.compile(r"^(?=[0-9]*[1-9])[0-9]{1,7}$", flags=re.MULTILINE)
test_str = ("1\n"
"12\n"
"432\n"
"12414\n"
"1234567\n"
"01\n"
"0121\n"
"0000001\n\n"
"0000000\n"
"0\n"
"12345678")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")