#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*[A-Z]+ {2,}[A-Z]+.*$"
Local $sString = "In this text," & @CRLF & _
"THE TREE IS GREEN should not match," & @CRLF & _
"THE TREE IS GREEN should" & @CRLF & _
"and so should THE TREE IS GREEN" & @CRLF & _
"but double-spaced text should not be flagged outside the pattern."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")