import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*[A-Z]+ {2,}[A-Z]+.*$";
final String string = "In this text,\n"
+ "THE TREE IS GREEN should not match,\n"
+ "THE TREE IS GREEN should\n"
+ "and so should THE TREE IS GREEN\n"
+ "but double-spaced text should not be flagged outside the pattern.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}