re = /^.*[A-Z]+ {2,}[A-Z]+.*$/m
str = 'In this text,
THE TREE IS GREEN should not match,
THE TREE IS GREEN should
and so should THE TREE IS GREEN
but double-spaced text should not be flagged outside the pattern.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end