package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*[A-Z]+ {2,}[A-Z]+.*$`)
var str = `In this text,
THE TREE IS GREEN should not match,
THE TREE IS GREEN should
and so should THE TREE IS GREEN
but double-spaced text should not be flagged outside the pattern.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}