$re = '/^.*[A-Z]+ {2,}[A-Z]+.*$/m';
$str = 'In this text,
THE TREE IS GREEN should not match,
THE TREE IS GREEN should
and so should THE TREE IS GREEN
but double-spaced text should not be flagged outside the pattern.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);