using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*(PeGaSuS.*(\@.*|.*joins.*|.*parts.*|.*leaves.*)).*$";
string input = @"<PeGaSuS@Network> say something
PeGaSuS joins #weechat
PeGaSuS parts #weechat
PeGaSuS leaves #weechat
<SomeNick@Network> PeGaSuS, could you give me an hand understanding this?
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}