import Foundation
let pattern = #"^.*(PeGaSuS.*(\@.*|.*joins.*|.*parts.*|.*leaves.*)).*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
<PeGaSuS@Network> say something
PeGaSuS joins #weechat
PeGaSuS parts #weechat
PeGaSuS leaves #weechat
<SomeNick@Network> PeGaSuS, could you give me an hand understanding this?
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)