$re = '/^.*(PeGaSuS.*(\@.*|.*joins.*|.*parts.*|.*leaves.*)).*$/m';
$str = '<PeGaSuS@Network> say something
PeGaSuS joins #weechat
PeGaSuS parts #weechat
PeGaSuS leaves #weechat
<SomeNick@Network> PeGaSuS, could you give me an hand understanding this?
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);