// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.*(PeGaSuS.*(\@.*|.*joins.*|.*parts.*|.*leaves.*)).*$").unwrap();
let string = "<PeGaSuS@Network> say something
PeGaSuS joins #weechat
PeGaSuS parts #weechat
PeGaSuS leaves #weechat
<SomeNick@Network> PeGaSuS, could you give me an hand understanding this?
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}