re = /^.*(PeGaSuS.*(\@.*|.*joins.*|.*parts.*|.*leaves.*)).*$/m
str = '<PeGaSuS@Network> say something
PeGaSuS joins #weechat
PeGaSuS parts #weechat
PeGaSuS leaves #weechat
<SomeNick@Network> PeGaSuS, could you give me an hand understanding this?
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end