#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[-0-9]+?[\.0-9]*"
Local $sString = "option value="-1" >Not Strated</option>" & @CRLF & _
" <option value="0" >Just Strated</option>" & @CRLF & _
" <option value="1.6" >1.6 % Done</option>" & @CRLF & _
" <option value="2">2 % Done</option>" & @CRLF & _
" <option value="2.6">2.6 % Done</option>" & @CRLF & _
" <option value="3">3 % Done</option>" & @CRLF & _
" <option value="3.6">3.6 % Done</option>" & @CRLF & _
" <option value="4">4 % Done</option>" & @CRLF & _
" <option value="4.6">4.6 % Done</option>" & @CRLF & _
" <option value="5">5 % Done<"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")