re = /[-0-9]+?[\.0-9]*/
str = 'option value="-1" >Not Strated</option>
<option value="0" >Just Strated</option>
<option value="1.6" >1.6 % Done</option>
<option value="2">2 % Done</option>
<option value="2.6">2.6 % Done</option>
<option value="3">3 % Done</option>
<option value="3.6">3.6 % Done</option>
<option value="4">4 % Done</option>
<option value="4.6">4.6 % Done</option>
<option value="5">5 % Done<'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end