import Foundation
let pattern = #"[-0-9]+?[\.0-9]*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
option value="-1" >Not Strated</option>
<option value="0" >Just Strated</option>
<option value="1.6" >1.6 % Done</option>
<option value="2">2 % Done</option>
<option value="2.6">2.6 % Done</option>
<option value="3">3 % Done</option>
<option value="3.6">3.6 % Done</option>
<option value="4">4 % Done</option>
<option value="4.6">4.6 % Done</option>
<option value="5">5 % Done<
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)