use strict;
my $str = 'option value="-1" >Not Strated</option>
<option value="0" >Just Strated</option>
<option value="1.6" >1.6 % Done</option>
<option value="2">2 % Done</option>
<option value="2.6">2.6 % Done</option>
<option value="3">3 % Done</option>
<option value="3.6">3.6 % Done</option>
<option value="4">4 % Done</option>
<option value="4.6">4.6 % Done</option>
<option value="5">5 % Done<';
my $regex = qr/[-0-9]+?[\.0-9]*/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}