package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[-0-9]+?[\.0-9]*`)
var str = `option value="-1" >Not Strated</option>
<option value="0" >Just Strated</option>
<option value="1.6" >1.6 % Done</option>
<option value="2">2 % Done</option>
<option value="2.6">2.6 % Done</option>
<option value="3">3 % Done</option>
<option value="3.6">3.6 % Done</option>
<option value="4">4 % Done</option>
<option value="4.6">4.6 % Done</option>
<option value="5">5 % Done<`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}