const regex = /^(?!$)(?!0+$)\d{0,5}(?:\.(?!0{1,2}$)\d{1,2})?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!$)(?!0+$)\\d{0,5}(?:\\.(?!0{1,2}$)\\d{1,2})?$', 'gm')
const str = `12345.12
0.12
00000.0
00000
00000.01
00001
00000.00
00000.000
12345.89
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}