$re = '/^(?!$)(?!0+$)\d{0,5}(?:\.(?!0{1,2}$)\d{1,2})?$/m';
$str = '12345.12
0.12
00000.0
00000
00000.01
00001
00000.00
00000.000
12345.89
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);