import re
regex = re.compile(r"^(?!$)(?!0+$)\d{0,5}(?:\.(?!0{1,2}$)\d{1,2})?$", flags=re.MULTILINE)
test_str = ("12345.12\n"
"0.12\n"
"00000.0\n"
"00000\n"
"00000.01\n"
"00001\n"
"00000.00\n"
"00000.000\n"
"12345.89\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")